Looks like some Comity services are not working

Major incident Comity
2020-09-16 00:46 PST · 1 hour, 16 minutes, 24 seconds

Updates

Resolved

Service is back up.

September 16, 2020 · 02:02 PST
Issue

Our team has been notified of the issue. If the outage persists, please contact our support.

September 16, 2020 · 00:46 PST

← Back