Looks like some ElixirXR services are not working

Major incident ElixirXR
2021-07-28 09:06 PDT · 7 minutes, 42 seconds

Updates

Resolved

Service is back up.

July 28, 2021 · 09:14 PDT
Issue

Our team has been notified of the issue. If the outage persists, please contact our support.

July 28, 2021 · 09:06 PDT

← Back