Looks like some ElixirXR services are not working

Major incident ElixirXR
2021-08-13 13:40 PDT · 7 minutes, 41 seconds

Updates

Resolved

Service is back up.

August 13, 2021 · 13:48 PDT
Issue

Our team has been notified of the issue. If the outage persists, please contact our support.

August 13, 2021 · 13:40 PDT

← Back