Looks like some Comity services are not working

Major incident Comity
2021-08-31 10:37 PDT · 4 minutes, 11 seconds

Updates

Resolved

Service is back up.

August 31, 2021 · 10:42 PDT
Issue

Our team has been notified of the issue. If the outage persists, please contact our support.

August 31, 2021 · 10:37 PDT

← Back