Looks like some Comity services are not working

Major incident Comity
2021-09-27 05:40 PDT · 9 minutes, 6 seconds

Updates

Resolved

Service is back up.

September 27, 2021 · 05:49 PDT
Issue

Our team has been notified of the issue. If the outage persists, please contact our support.

September 27, 2021 · 05:40 PDT

← Back